Archives de catégorie : OVH

OVH, modem Thomson TG784n, IPv6 + HTTPS = KO, solution

Depuis quelques temps mes connexions HTTPS en IPv6 fonctionnaient mal (voir plus du tout vers de l’hébergement OVH, quelle ironie). Cause: ce magnifique modem (hem hem) avait un bug de QoS (je n’ai pas les détails) pouvant être résolu en se connectant en telnet sur le modem et en entrant la commande suivante:

label modify name=AF41 tosmarking=disabled

Qui peut être annulée avec:

label modify name=AF41 tosmarking=enabled

Merci à la personne qui me l’a donnée sur la mailing list OVH.

Bizarrement le problème ne se manifestait pas sur une Ubuntu 13.10 et 14.04, alors j’avais entrepris de comparer le trafic avec Wireshark. J’aurais pu encore chercher longtemps dans cette direction…

OVH met fin aux offres ADSL bêta et gamma les moins chères :-(

Triste revirement d’OVH. Selon son fondateur sur la mailing list, certaines leurs coûtent plus qu’elles ne leur rapportent. Je comprends sans peine pour des offres bêta à 10€ (HT). Mais s’être planté dans la rentabilité pour les offres «gamma» (dont la no!tv à 24€TTC, qui me convenait bien), ça ne donne pas une image de fiabilité auprès du client.

Au début de l’offre, j’ai du attendre 3 semaines pour avoir le téléphone (plus 1 semaine de migration ADSL). L’IPv6 promis a mis 10 mois (bref, je l’ai depuis 2 mois) pour arriver. Si j’avais été méchant, je me serais plaint auprès de la répression des fraudes et demandé un remboursement. J’avais également acheté pour l’occasion des adaptateurs CPL pour remplacer ceux de Free.

Je vais donc sûrement repartir chez Free (sauf si ma ligne est considérée comme rentable pour OVH). Je vais payer un peu plus cher, mon boîtier télé va rester dans le placard, les débits Youtube seront ridicules, mais j’aurai de la fibre et un abonnement téléphone pour le micro-consommateur de mobile que je suis.

wget, logs apache OVH et erreur SSL

Depuis peu (en fait peut-être depuis le passage à Kubuntu 12.04), je ne pouvais plus récupérer par wget les logs de mon hébergement OVH. J’avais l’erreur suivante (avec wget -d):

Résolution de logs.ovh.net (logs.ovh.net)... 213.186.33.7
Caching logs.ovh.net => 213.186.33.7
Connexion vers logs.ovh.net (logs.ovh.net)|213.186.33.7|:443... connecté.
Created socket 3.
Releasing 0x00000000006b8be0 (new refcount 1).
Initiating SSL handshake.
SSL handshake failed.
Closed fd 3
Incapable d'établir une connexion SSL.

La solution a été de rajouter le paramètre «–secure-protocol=SSLv3».

OVH ADSL après deux mois

Voila ce que je retiens après deux mois avec l’offre OVH no!TV:

  • débits généralement bons
  • parfois ils chutent fortement (100ko/s en réception, malgré une synchronisation haute), une reconnexion manuelle ou un redémarrage du modem résolvant le problème
  • il m’arrive aussi que mon téléphone portable ne puisse plus se connecter en Wi-Fi, et il me faut redémarrer le modem (ce qui est long et frustrant). En fait, il m’a fallu manuellement choisir un canal Wi-fi (le mode automatique ne fait apparemment pas le bon choix), et depuis plus de problème.
  • mon vieux répondeur analogique ne détecte pas lorsque le correspondant raccroche, ce qui me laisse des messages interminables ponctués de bips. C’est clairement un bug du Thomson TG784n.

Billet précédent sur OVH no!TV.

OVH ADSL après un mois

Un mois après, voila ce que j’ai retenu de l’offre OVH no!TV en dégroupage total:

  • 1 semaine pour être déconnecté par Free et FT, une autre semaine pour recevoir le modem OVH (ils auraient pu le faire en parallèle)
  • le service de base, c’est à dire Internet en IPv4, était fonctionnel à la réception du modem (et même un peu avant si on a déjà un modem). Les débits sont très bons, parfois variables (download pouvant être divisé par deux, mais je ne vois pas à l’usage la différence quand ça arrive)
  • les dégroupés partiels peuvent avoir de gros problèmes de débit (merci l’opérateur qui effectue la collecte ADSL)
  • chez moi Youtube fonctionne à plein débit (contrairement à Free), d’autres ont eu un problème d’IP bannies par Google car dans la même plage que des spammeurs (machines d’hébergement)
  • 3 semaines sans téléphone!!! Leur procédure d’auto-configuration de la partie téléphonie du modem a de gros ratés, et ils ont été très longs à la rétablir manuellement, en communiquant très peu sur la résolution de ce problème.
  • Comparé à Free: La téléphonie n’est pas du SIP, mais on a les communications vers les mobiles inclues
  • la facturation a apparemment commencé à la date de réception du modem, ce qui est honnête.
  • concernant le support d’IPv6, j’hésite à qualifier leur formulation de maladroite ou de malhonnête. Il semble s’avérer qu’il faille choisir entre soit IPv4 + téléphonie, soit IPv6 (avec l’IPv4? pas sûr! et pas de téléphonie!). En effet, pour avoir de l’IPv6, il faut mettre le modem en moteur bridge, dans quel cas il va relayer la liaison à un autre équipement de l’abonné (autre routeur, ordinateur) qui va gérer l’authentification et la distribution d’adresse. Mais dans ce cas-là, le modem ne fait plus d’IP, donc adios le SIP, donc plus de téléphone. Verra-t-on un firmware qui gère tout comme les Freebox? Pas sûr!
  • l’interface web de ce modem est lente comme un veau. Ça inspire tellement confiance que je préfère le laisser dans son coin et ne plus toucher maintenant que ça fonctionne.

Pour moi, l’offre est encore bêta, et si vous vous inscrivez, faîtes le en sachant à quoi vous attendre. Indispensables: le forum et la liste de diffusion.

OVH No!TV ADSL me voila

Mise à jour: En fait ma liste était peut-être déjà active. J’ai utilise un programme nommé “installemodem” pour Debian/Ubuntu pour me connecter, mais celui-ci ne fonctionne qu’aléatoirement. En faisant une connexion en ligne de commande, cela fonctionne à tous les coups. Les modems ethernet sont quand même plus pratiques…

J’ai enfin migré de Free vers OVH. Déroulement des évènements:

  • un samedi: inscription pour leur offre en dégroupage total via leur site web. Envoi de la lettre de résiliation A/R pour Free gratuitement
  • J+6, vendredi: ma ligne France Télécom est coupée. Mes identifiants Free Wi-fi ne sont plus valides (ils auraient pu me les laisser jusqu’à la fin du mois!).
  • J+12, jeudi: ma connexion ADSL est établie. J’utilise mon vieux modem Sagem F@st 800 que Free avait abandonné au passage vers la Freebox. Finalement il m’aura été utile. Pour le moment ce sera ADSL de base (et pas ADSL 2+).
  • J+12 encore, le modem d’OVH est expédié. Ils avaient sous-estimé la demande. Ont-ils attendu cet événement pour valider ma ligne? Si c’est le cas, c’est bien mal joué de leur part. Ayant été débité dès le premier jour, j’ai perdu 24*11/31 = 8.5€. Là encore, c’est moyen de leur part.
  • J+14: le modem est arrivé. Mise en œuvre simple. 1.6Mo/s en download, 93ko/s en upload, ping de 50ms. Le téléphone n’est toujours pas activé. Par contre le truc super fun est qu’on configurer sa ligne pour faire un serveur vocal basé sur VoiceXML (avec des menus, de la voix synthétisée…).
  • J+16: j’ai eu brièvement le téléphone. Étant tombé sur un bug du modem (si on utilise un caractère accentué, impossible de se connecter dans l’interface d’admin), j’ai dû faire une réinitialisation avec les paramètres d’usine et ai perdu ma config SIP. Après appel au support, elle aurait dû se reconfigurer à distance, mais ce n’est toujours pas le cas.